How to fix VMware Converter error “FAILED: The VSS snapshots cannot be stored”

While moving some VM’s from Hyper-V to VMware using VMware Converter a VM failed to convert with the error: FAILED: The VSS snapshots cannot be stored.

FAILED: The VSS snapshots cannot be stored because there is not enough space on the source volumes or because the source machine does not have any NTFS volumes. Error code: 2147754783 (0x8004231F).

Come to find out the System Reserved partition was full. Our soon to be retired Appassure backup application was nice enough to fill up the volume.

Luckily Appassure is being replaced by Veeam and fixing the above VMware Converter error is an easy fix.

Steps on how-to fix VMware Converter “FAILED: The VSS snapshots cannot be stored” error message

  1. Open Computer Management by pressing Windows Key+R and typing in compmgmt.msc, then go to Disk Management.
    computer management
  2. Right click on the System Reserved partition and select Properties.
    system reserved properties
  3. Then click on the Shadow Copies tab and ensure Shadow Copies are disabled for each volume and then close the Properties window.
    system reserved shadow copies
  4. Again, right click on the System Reserved partition and then select “Change Drive Letter and Path…” and assign the partition a drive letter (I’ll be using letter Z).
    system reserved drive letter
  5. Next open the Z: drive in File Explorer and right click on System Volume Information folder and select Properties.
    system reserved z drive
  6. In the System Volume Information Properties window, click on the Security tab then click on Advanced to open the Advanced Security Setting dialog box.
    system volume information advanced
  7. Now add the Everyone group Full control to the folder, subfolders and files.
    advanced security settings
  8. Right click on Start Menu icon and select Command Prompt (Admin) to open a Command Prompt as Administrator.
    command prompt as admin
  9. Now type in the following commands:
    
    Z:
    fltmc unload aafsflt
    cd "System Volume Information"
    del aalog_*
    cd ..
    fltmc load aafsflt
    

    delete logs commands
    Then exit the command prompt.

  10. Finally be sure to remove the Everyone access from the System Volume Information folder (steps 6 & 7) and remove the drive letter (step 4).

Now re-run your VMware Converter task again and the migration should work without issue!

Similar Posts

  • VMware vCenter Server 5.5b released

    vmware vcenter 5.5b released

    VMware hasn’t let the holidays get in their way and has released vCenter Server 5.5b (Build 1476387) along with vCenter Server Appliance 5.5.0b (Build 1476389). The update includes a number of fixes.

    Resolved Issues in 5.5.0b

    Upgrade and Installation

    • Upgrading the vSphere Web Client to vSphere 5.5 fails with an error
      Attempts to upgrade the vSphere Web Client to vSphere 5.5 fails when they are installed in a custom, non-default location. An error message similar to the following is displayed:

      Error 29107. The service or solution user already registered...

    Read More “VMware vCenter Server 5.5b released”

  • How to update VMware Windows VM’s DNS using PowerCLI

    This post will show you how to update a VMware Windows virtual machine’s DNS IP addresses using PowerCLI.

    You’ll also see how I went from a starting point to a fully working script – all thanks to the awesome #vCommunity!

    Here at work we’ve been doing a number of networking, AD, and DNS changes. In doing so, our DNS IP address have changed. Changing the DNS settings for our workstations was easy, simply edit the DHCP scope.

    The servers on the other hand all had static IP’s and static DNS IP’s entered, each of which needed to be updated.

    Read More “How to update VMware Windows VM’s DNS using PowerCLI”

  • VMware Site Recovery Manager 8.2 – No more Windows

    VMware has just announced the release of Site Recovery Manager 8.2. There are a number of new items in SRM 8.2, such as enhancements to the HTML5 user interface, support for vSphere 6.7 Update 2, but most notably is Site Recovery Manager 8.2 virtual appliance!

    No more Microsoft Windows license needed! The SRM 8.2 virtual appliance runs on the Photon OS distro, which is similar to what the vCenter virtual appliance has been running on for years now.

    Read More “VMware Site Recovery Manager 8.2 – No more Windows”

  • Thank you VMware Community!

    VMware vExpert 2014

    So far, 2014 has been a very rewarding year for a number of reasons, two of which has happened in just a week or two span. First, Eric Siebert (@ericsiebert) announced on March 27th, this years results of the 2014 Top VMware & Virtualization Blog voting. My first year entered into voting and made it to 71st place! A huge thanks goes out to not only Eric but just as much so to everyone who voted for me!

    To top it off, yesterday VMware announced 2014’s first quarter VMware vExpert list. While vExpert isn’t a technical certification or even a general measure of VMware expertise. The VMware judges selected people who were engaged with their community and who had developed a substantial personal platform of influence in those communities. There were a lot of very smart, very accomplished people, even VCDXs, that weren’t named as vExpert this year. VMware awarded this title to 754 people this year and on that list of many impressive names you’ll find yours truly, Michael Tabor!

    I’m both honored and humbled by both lists. It’s a great feeling to be recognized by not only my peers through the voting in the Top vBlog but also by VMware themselves through the vExpert title.

    So again THANK YOU very much to the entire VMware community, a spectacular community indeed, and congratulations to everyone else that made the Top vBlog and vExpert lists!

  • VMware Workstation 11 released

    VMware Workstation 11 Unmatched OS Support

    At the start of October VMware announced Workstation 11, along with VMware Player 7 Pro and said both products would be available sometime in December. Well today is the day, VMware has now officially released VMware Workstation 11!

    Workstation 11 adds support for the latest version of Windows and Linux, as well as the latest processors and hardware, and also adds the ability to connect to VMware vCloud Air.

    Read More “VMware Workstation 11 released”

  • VMware View client now availabe for Android!

    VMware has announced that they have released a View Client for Android tablets available on the Android Market now. Here are just a few of the features found on the new client.

    • A new look and feel – The View Client for Android features the NEW blue look and feel of the VMware View clients!
    • Multiple broker support – If you have more than one VMware View broker in your organization, you can can easily access your desktop from all of them via the Android client
    • Desktop Shortcuts – Quickly connect with as many as four recent desktop via shortcuts
    • Virtual trackpad – Control your desktop on a granular level just like you would control the mouse on a laptop
    • Custom keyboard toolbar – Super easy access to all of the special keys not found on the Android default keynboard
    • Honeycomb 3.x support – Made from the ground up for the new generation of Android tablets
    • Custom gestures – Invoke keyboard, scrolling, etc are as easy as ever and simple to use
    • VMware View Security Server support (best experience) – No need to have VPN when you use VMware View Security Server
    • Background tasking – Switch between apps on your tablet and come right back

Leave a Reply

Your email address will not be published. Required fields are marked *

2 Comments

  1. I resolved this issue another way. I assigned a drive letter to the recovery partition in preparation to remove suspected journal files, however that was not the problem. Opening the drive letter for the recovery partition revealed an installation of Kaspersky anti-virus taking up 73 mb. Removed that , removed the drive letter and I no longer get the Vss shadow copy error. I would recommend people assign a drive letter and see if they see data on the recovery drive which should not be there. Do not delete stuff if you do not know what it is for, such as any files with the word “boot” in them. Also, if you see only a few files which do not add up to 100 mb, google for how to remove journal files. That might be the problem.

  2. If you cannot acces to the system reserved you can open this partition by linux mint live cd. when I opened partition and I delete all recovery folder ( becouse I don’t need this folder. I made backup by acronis wd). after this operation I have 400 MB free space and I can convert machine now. Best regards. Pawel from Poland