VMware Update Manager U3e upgrade failing? Un-install it!

VMware Update Manager U3e error

I was recently upgrading a VMware environment from vCenter Server Update 3b to Update 3e and during the scheduled change I had also planned on upgrading VMware Update Manager to Update 3e and ran into the following error:

VMware Workstation unrecoverable error: (vthread-3)
GetProcAddress: Failed to resolve ENGINE)load_aesni: 127
You can request support.

Looking for a possible solution at the VMware Knowledge Base came back with no results and to error message wasn’t overly useful either with “VMware Workstation unrecoverable error: (vthread-3)” as Workstation wasn’t installed on this server.

I’ve upgraded VUM plenty of times without any issues and even Update 3e detected Update Manager was already installed and prompted me that it was going to upgrade it:

vmware update manager u3e upgrade prompt

So in theory the upgrade should have worked just fine, but even still the error at top continued.

How to upgrade VMware Update Manager to Update 3e

Lucky for us the fix is quick and easy – simply un-install VUM.

  • Un-install the existing VUM instance.
  • Re-run the VMware Update Manager U3e installer and install VUM as normal.

Your settings and baselines will not be effected as they are stored in the database and so long as you tell the installer to use the existing database all that information will be there after you re-install Update Manager Update 3e.

An easy fix for a very useful program! If VMware provides an alternate fix I’ll be sure to update this post.

Similar Posts

  • Improve Linux VM IO performance by disabling IO Scheduler

    For a little while now we’ve been seeing RedHat Linux virtual machines performing poorly. Tasks would take considerably longer on the Linux VM’s then other Windows VM’s. After digging around I eventually found that RedHat has it’s own IO scheduler that runs in the background. On a physical box this wouldn’t be a big deal, but as a virtual machine everything is already being processed by VMware hypervisor. The fix, disable the IO Scheduler!

    Read More “Improve Linux VM IO performance by disabling IO Scheduler”

  • VMware vCenter Server 5.5b released

    vmware vcenter 5.5b released

    VMware hasn’t let the holidays get in their way and has released vCenter Server 5.5b (Build 1476387) along with vCenter Server Appliance 5.5.0b (Build 1476389). The update includes a number of fixes.

    Resolved Issues in 5.5.0b

    Upgrade and Installation

    • Upgrading the vSphere Web Client to vSphere 5.5 fails with an error
      Attempts to upgrade the vSphere Web Client to vSphere 5.5 fails when they are installed in a custom, non-default location. An error message similar to the following is displayed:

      Error 29107. The service or solution user already registered...

    Read More “VMware vCenter Server 5.5b released”

  • How to convert VMDK to OVF file format

    Here is a quick and easy way to convert a VMDK to OVF file format using the OVF Tool from VMware.

    1. First download and install the VMware OVF Tool for your operating system.
    2. Open a command prompt as Administrator and navigate to the OVF Tool install directory:
      
      cd C:\Program Files\VMware\VMware OVF Tool
      

      vmdk to ovf command prompt

    3. Next, type in the following command to convert VMDK to OVF:
      
      ovftool.exe \virtualmachine.vmx \virtualmachine.ovf
      

      convert vmdk to ovf command

    After a few minutes time you should you should see a “Transfer Completed, Completed successfully” message and your VMDK to OVF file conversion is complete and ready for use.
    convert vmdk to ovf complete

  • My VMware View Windows 7 Optimization Guide

    These are the few steps I do when creating a new "Golden" image. Luckily I don’t have to do these steps all the time as I’ll create the "Golden" image when there is a new upgrade such as when we went from View 4.6 to View 5.0.1. I like to have a new fresh machine using new virtual hardware from the start. You could certainly just upgrade the virtual hardware on the "Golden" image, I just prefer to start clean.

    At any rate, here’s my list. Hopefully someone might find it somewhat useful and maybe even others can improve upon it.

    Preparing a new virtual machine

    1. Create New Virtual Machine – FILE > NEW > VIRTUAL MACHINE (CTRL+N)
    2. Under Configuration select CUSTOM.
    3. Select a Name, Folder, Host, Cluster, and Storage.
    4. Under Guest Operating System select Windows and then Windows 7 32bit under the Version drop down.
    5. Select which Network (VLAN) and under Adapter select VMXNET 3.
    6. Configure disk size to 30GB THIN provisioned.

    Read More “My VMware View Windows 7 Optimization Guide”

  • How to install VMware vSphere Update Manager 5.5

    If you don’t already know, VMware Update Manager (aka, VUM) is a tool which allows you to easily automate patching and upgrading VMware hosts as well as virtual machine hardware and VMware tools. It’s a wonderful tool and makes upgrading and patching so much easier and allows you to quickly see how compliant/up-to-date your environment is with the built in pie graph.

    Recently we had some pretty serious array issues which corrupted the VUM database taking Update Manager down. Since we was going to have to rebuild Update Manager I opted to move from Windows Server 2008 to Windows Server 2012, in the steps below I’ll document step by step how to install VMware Update Manager 5.5 on Server 2012 and a separate database.

    Read More “How to install VMware vSphere Update Manager 5.5”

  • How to update VMware Windows VM’s DNS using PowerCLI

    This post will show you how to update a VMware Windows virtual machine’s DNS IP addresses using PowerCLI.

    You’ll also see how I went from a starting point to a fully working script – all thanks to the awesome #vCommunity!

    Here at work we’ve been doing a number of networking, AD, and DNS changes. In doing so, our DNS IP address have changed. Changing the DNS settings for our workstations was easy, simply edit the DHCP scope.

    The servers on the other hand all had static IP’s and static DNS IP’s entered, each of which needed to be updated.

    Read More “How to update VMware Windows VM’s DNS using PowerCLI”

Leave a Reply

Your email address will not be published. Required fields are marked *