vSphere 5.1 and View 5.1 are finally compatible

As mentioned before, I mentioned vSphere 5.1 currently not compatible with any VMware View version. As of yesterday, VMware has finally released a patch (ESXi510-201210001) to correct the incompatibility issues.

Alternatively you can also download an updated ESXi 5.0 ISO. To download the ISO:

  1. Navigate to the vSphere Download Center.
  2. Click View Download for the VMware ESXi 5.1.0 Installable for your version of ESXi.
  3. On the Product Downloads tab, download VMware-VMvisor-Installer-201210001-838463.x86_64.iso.

KB 2035268